Import matching and cleared transactions

I’ve noticed when importing CSV files and going through matching that the system doesn’t check against cleared transactions, which can lead to me creating new transactions, ultimately resulting in duplicate cleared transactions.

Is there something off with my workflow, or a workaround that I should be using when I’m trying to review and clear my transactions?

I’ll wait for the admins (@alex?) to weigh in on .csv imports, but if you’re able to import data as a Quicken file (.qfx) it will behave the way you want it to. This is my default for all imports and it works very smoothly. But I’m also curious as to why the .csv behaves differently!

Hi wordygwj,

Thanks for posting and sorry for the trouble! Goodbudget should be able to check the transactions you’re importing against your existing transactions, so you don’t accidentally create duplicates.

If that’s not happening, it might be because the Name, Date, or Amount of the transactions in your files are changing from file to file. To clarify, when you use a CSV file to import with, Goodbudget creates a special identifier for each transaction based on their Name, Date and Amount. If any of those pieces of information change, Goodbudget will think it’s an entirely new transaction and therefore allow you to import again. I’ve seen this kind of thing happen specifically with CSV files that had transactions that had not cleared in the Goodbudgeter’s bank yet. When the transaction finally cleared, the Name, Date, or Amount changed and resulted in them importing the transaction again. Hope that made sense!

Tiffany’s suggestion of using a QFX might work. If your bank offers them, feel free to give it a try. But, you might be better off filtering your CSV file for a date range that doesn’t overlap with transactions you’ve already imported. You could even edit your CSV file directly to remove transactions that are still pending, in case that was the issue.

Hope that helps!

I’m actually not seeing cleared transactions on the right column at all. If it’s been previously matched it (correctly, but perhaps unhelpfully) isn’t displayed in either column. If the Goodbudget transaction is marked as cleared, the transaction isn’t displayed, either.

I appreciate the QFX suggestion, but unfortunately the system I’m pulling from only offers CSV downloads. I’m willing to do the work by hand to match imported transactions to already cleared entries, but I need to be able to see the cleared transactions to do that.

1 Like

@Karisa, is this new? I don’t remember it dropping cleared transactions from the imported comparisons before, but I get the same behavior if I try to import a .csv. Why doesn’t it match them the same way the .qfx files do?
(Chrome v. 85.0.4183.83; Mac Mojave v. 10.14.6)

Hi all,

I apologize, as I think I misunderstand wordygwj’s first post. I thought you were saying that you were seeing transactions you’ve already imported showing up in the Existing Transactions column, and therefore were creating duplicates.

I think you’re wondering why Goodbudget isn’t checking your Transactions to Import against transactions you’ve marked as Cleared. Is that right?

If so, the answer is, it should. As long as those transactions haven’t been imported before (which would mean they’ve been branded with a FITID), then Goodbudget should be serving them to you under the Existing Transactions column.

If that’s not what you’re experiencing, email us at support@goodbudget.com and let us know which transaction(s) that you’ve marked as Cleared but are not showing on the import screen.

Of course, if I’m still misunderstanding you, please don’t hesitate to let me know :smiley: Thanks for your patience!

I’m new to this forum method of support but this looks like the closest thing to the problem I am having. I recently discovered the “import bank transactions” option, which will be awesome once I can get my accounts to match.

The problem I am having is similar to what was listed in the original question. When I import bank transactions in CSV format it shows the bank transaction column but many of my Goodbudget transactions are not there. I’m not sure if this is due to those transactions being previously matched/imported or being cleared, but if that was the case then why are the bank transactions showing up? If they have already been matched/imported then both should be gone or both should be there???

I tried the QFX method. In that case only the bank transactions column is populated and there is nothing in the goodbudget column.

I really like goodbudget and like the transaction import even more but I really need it to be able to match transactions so I can identify discrepancies such as transactions I forgot to add, double added, or had a typo on.

Please help! =)

QFX is my favorite, and it will only attempt to match transactions that aren’t reconciled (I think), and the reconciliation function is limited to the dates you’ve indicated on the import screen. For example, if you’ve marked all of your May transactions as reconciled and then you attempt to import and reconcile the May statement, you won’t see any Goodbudget transactions. Also, if your bank records a transaction on May 30 but your entry in GB is dated June 1, it won’t show up as an option during reconciliation.
You might try changing “reconciled” transactions that haven’t been matched to your most recent statement to “cleared” and then trying again; Goodbudget should attempt to match them up while showing you any that don’t match.
Finally, don’t manually mark any transactions as Reconciled. Just “clear” them, and let the system “reconcile” them when you go through the formal reconciliation process.
I’m not sure any of this helps, but I hope so!

Edit: Importing bank transactions will Clear them, and going through the Reconciliation process will change them to Reconciled.

Second edit: I’m pretty sure you can only import transactions once; if you’ve already done it then GB will ignore them the next time around.

Thank you for your reply! I am running into a couple of problems at the moment.

The first is that I imported my bank transactions but then wanted to confirm some things and tried to import again hoping that the transactions were matched would again show up so I could cross check them. The problem is the bank transaction show up but the Good Budget transactions that were already imported from the bank are not showing up and it is allowing me to import transactions that were already imported and matched. Is there a way to reset this so both sides show up?

I tried making the “unchecking” the Good Budget transactions so they are not reconciled but that does not seem to change anything unless there is another step I am missing there to make the app recognize that they are not reconciled.

Specifically for the purposes of preventing already-Imported transactions from appearing again and confusing matters for future uploads, they are blocked from showing up again in future Imports. This blocking is related to code that isn’t visible within the app itself, so it’s not possible to have already-Imported transactions appear again in the Import process, even if you change their status from Cleared or Reconciled back to nothing.

The only way to reset this, as you’re imagining, would be to delete all the transactions in your household that match the Import so Goodbudget doesn’t see anything as matching.