Date format when exported to CSV file

When I export report data to a CSV file and open that in Excel the formatting of the dates is inconsistent. Not all of them are recognized as dates in Excel, although some are. Strange, but true.

Hi @Doug_Fordham - Thanks for posting, and sorry for the trouble! Are you seeing ‘####’ in place of some dates? If so, I think that’s just what happens when the date is longer than the column is wide. Try widening the column and you should see the dates appear. Hope that helps!

Thanks for trying, but no, I’m afraid it’s not as simple as that. Sometimes the format is 06-01-23 and sometimes, within the same worksheet it’s 05/29/2023. Both those cells will show as being date formats in Excel but the second one is not actually a date number so I can’t use it.

Sorry about that. I wasn’t able to reproduce the issue–can you email us directly at with your household username so we can take a closer look? In the meantime, you should be able to bulk change the date format by selecting the column in Excel.

I am searching this topic for an answer but I can provide more information to you about the problem.

In regards to the initial question about date inconsistency. Have you noticed if the problems appear if the day and month are switched?

January 1, 2023 will be 1/1/2023

But April 1, 2023 could be 1/4/2023 or 4/1/2023 depending on your Good Budget settings.

The bigger problem would appear for May 15, 2023. This could appear as 5/15/2023 but if your system is looking for dd/mm/yyyy it will have problems understanding the 5th day of the 15th month!

The CSV export format is a US format of MM/DD/YYYY or can be changed in “My Household” settings to DD/MM/YYYY
The international format (ISO) is YYYY/MM/DD

When I export transactions from GoodBudget the date column is presented in the CSV as MM/DD/YYYY so Excel on my computer treats this as general text and therefore cannot be sorted by date nor am I able to apply date formatting to display it differently.

I see within “My Household” preferences to change the date format to present the day or the month first. Neither is a solution that matches the International (ISO) standard.

How can I change my Good Budget settings to use the International Date format?

Hi Mits – the ISO date format is not available on the Goodbudget web at this time. The two formats showing in the household preferences are the two currently available.